[3.0b] not working for me...

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[3.0b] not working for me...

Gilles
Sorry to say this, but 3.0b is not working for me.

I include the files in this order:

CSS:
/js/3rd/shadowbox/shadowbox.css

Javascript:
js/3rd/shadowbox/shadowbox.js
js/3rd/shadowbox/adapters/shadowbox-jquery.js
js/3rd/shadowbox/languages/shadowbox-nl.js
js/3rd/shadowbox/players/shadowbox-img.js


This should be enough, but errors keep popping up:
In this case "g" is undefined, referring to the source at line 789...
Why this is happening is totally unclear to me.
Reply | Threaded
Open this post in threaded view
|

Re: [3.0b] not working for me...

sivel
Are you also including the jQuery library?  I don't see that in your list.

In order for shadowbox to work with the shadowbox jquery adapter you need to also load jquery.  Otherwise you need to use the base adapter.
Reply | Threaded
Open this post in threaded view
|

Re: [3.0b] not working for me...

Gilles
Yes, all libs are included.

Even if i do this it breaks:

<link rel="stylesheet" type="text/css" href="/js/3rd/shadowbox/shadowbox.css">
<script type="text/javascript" src="/js/3rd/shadowbox/shadowbox.js"></script><script type="text/javascript"> Shadowbox.init({ adapter: 'base', // To prevent jQuery adapter language: 'en', players: ['img'] }); </script>

Even the version on your site (which is 17, compared to the beta which is 16) breaks

My browser is firefox 3.0.5
Reply | Threaded
Open this post in threaded view
|

Re: [3.0b] not working for me...

mjijackson
Administrator
In reply to this post by Gilles
Gilles wrote
Sorry to say this, but 3.0b is not working for me.

Don't be sorry. I'm not that easily offended. :)

Gilles wrote
This should be enough, but errors keep popping up: In this case "g" is undefined, referring to the source at line 789... Why this is happening is totally unclear to me.

What browser are you using? Do you have a sample page that I could look at?

Reply | Threaded
Open this post in threaded view
|

Re: [3.0b] not working for me...

Levi Stanley
Yes, I am having trouble as well.

I am getting this error:

uncaught exception: Unable to load Shadowbox skin, base library not found.


Example: http://laptop.vibing.com