Quantcast

IE6 & 7 Problems w/ mootools

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

IE6 & 7 Problems w/ mootools

Stentor
Hello,

First I just want to say thank you, and that I love this javascript. I am using the new 1.0 released today with mootools as the framework. It is working great in Firefox, Opera, Safari, etc, but is not working in IE6 & 7. If you are using it with any media files, it simply has the ie prompt to download the media. If you are shadowboxing an external page, it just goes to that external page instead of shadowboxing it.You can see an example here(username and password are both "test". You can also view the thread that we have going in another forum here. Thank you in advance for your help.

Stentor
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: IE6 & 7 Problems w/ mootools

mjijackson
Administrator
Why are you using

window.addEvent(Shadowbox.init(options));

? That doesn't make any sense. It should just be

Shadowbox.init(options);

once you're already inside the domready handler function.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: IE6 & 7 Problems w/ mootools

Stentor
Ok, I changed this (on my own local project), but still no luck in ie6 & 7. Unfortunately, the example site that I gave you was not mine (but is having the identical problem), so I'll publish my own example with this change for you/everyone to look at as soon as I get home. Thanks for the help.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: IE6 & 7 Problems w/ mootools

Stentor
In reply to this post by mjijackson
It did actually work either way, it was just an extra comma at the end of the source files being listed.....

But on another and only related to internet explorer as well, the controls are not showing in a quicktime movie. This is happening on my site as well as viewing on yours shown here. Is there something that can be done?

Thank you again for the help, and I love this js!
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: IE6 & 7 Problems w/ mootools

mjijackson
Administrator
Hmm...that's an interesting screenshot. It's leaving a space for the controls, but for some reason the browser isn't rendering them. Can you show me the code you're using?
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: IE6 & 7 Problems w/ mootools

Stentor
After viewing over and over again, I found that it only happens "sometimes". I know that isn't the best response, but I'm not a js guru . The qt controls on your site work for me now, but not other times (only on ie6 of course), and the same goes for my site; sometimes the qt controls do show, and sometimes not. You can view my shadowboxed pages here.Thanks for the help.
Loading...