Shadowbox not always visible

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Shadowbox not always visible

George
Excuse my 'bad' English

What I think is a little unfortunately when you activate the box, say you are in the 2nd or 3rd 'scrolled' (down) page. The box stay (remain) always on top of the active page. This is confusing because you first have to scroll back up to see the effect. I have searching in the css, but I could'nt found something. Question is: is it possible te change this?

George (from Holland)














Reply | Threaded
Open this post in threaded view
|

Re: Shadowbox not always visible

arttronics
The issue you described occurs when you do not have a valid DOCTYPE on your webpage.

The most common type is XHTML 1.0 Transitional but your needs may be different.

When posting your markup here on the forum follow these simple steps:

0. Login and paste your markup into the Message Box.
1. Mouse select the markup you just pasted.
2. Press the More Button from the Message Box Toolbar.
3. Select Raw text from the drop down menu. DONE!

If I don't respond to your POST, it's your inability to provide your markup correctly.

Check out a few DEMOS I made that are here in this forum.

Reply | Threaded
Open this post in threaded view
|

Re: Shadowbox not always visible

George
Thank you very much,

 it works perfectly! So simple, but you just have to know! You're a real expert!

Old....... <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
New.......<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN">

George
Reply | Threaded
Open this post in threaded view
|

Re: Shadowbox not always visible

arttronics
Don't forget to change the html tag to reflect the new DOCTYPE.

Use this if required:
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">

You can also upload your file or test your link at the free online W3C Markup Validation Service.

When posting your markup here on the forum follow these simple steps:

0. Login and paste your markup into the Message Box.
1. Mouse select the markup you just pasted.
2. Press the More Button from the Message Box Toolbar.
3. Select Raw text from the drop down menu. DONE!

If I don't respond to your POST, it's your inability to provide your markup correctly.

Check out a few DEMOS I made that are here in this forum.

Reply | Threaded
Open this post in threaded view
|

Re: Shadowbox not always visible

George

Thank you..

You mean it is better that on every page; these codes in the head should be?
Or only when something is not working correctly?

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">
Reply | Threaded
Open this post in threaded view
|

Re: Shadowbox not always visible

arttronics
This is what I use. Adjust it as you need to:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">

<head>
    <title>Webpage Title Goes Here</title>

    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

When posting your markup here on the forum follow these simple steps:

0. Login and paste your markup into the Message Box.
1. Mouse select the markup you just pasted.
2. Press the More Button from the Message Box Toolbar.
3. Select Raw text from the drop down menu. DONE!

If I don't respond to your POST, it's your inability to provide your markup correctly.

Check out a few DEMOS I made that are here in this forum.

Reply | Threaded
Open this post in threaded view
|

Re: Shadowbox not always visible

George
Thank you very much!!

George
Reply | Threaded
Open this post in threaded view
|

Re: Shadowbox not always visible

Vitaly
Few days ago, I noticed that if you don't include www. before your index name shadowbox won't work. Why is that...?
Reply | Threaded
Open this post in threaded view
|

Re: Shadowbox not always visible

arttronics
Your post has nothing to do with this thread.

For your off-topic question, Google why is www necessary.

When posting your markup here on the forum follow these simple steps:

0. Login and paste your markup into the Message Box.
1. Mouse select the markup you just pasted.
2. Press the More Button from the Message Box Toolbar.
3. Select Raw text from the drop down menu. DONE!

If I don't respond to your POST, it's your inability to provide your markup correctly.

Check out a few DEMOS I made that are here in this forum.