rollover conflict

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

rollover conflict

jayecolina
Hi!

I downloaded the Shadowbox files today and was experimenting with it. I got it to play a QuickTime video on the provided Index page and I then substituted one of my QT videos in a successful test. When I linked one of my pages to the copied Javascripts and CSS and adapted the links to an image, the video kept opening in a new window. I found that by deleting the preloading of navigation rollover images and rollover Javascript, Shadowbox would show the video as it's supposed to.

My question is: How is it possible to utilize Shadowbox WITH rollover scripts and preloaded images?

Any suggestions will be greatly appreciated.

Thanks,
JC
Reply | Threaded
Open this post in threaded view
|

Re: rollover conflict

jayecolina
I forgot to mention that I am able to use Lightbox on similar pages (pages with the same rollover navigation, etc.) without any conflicts. I hoped to switch to Shadowbox due to it's sleeker appearance and ability to show more than photos.

Thanks
Reply | Threaded
Open this post in threaded view
|

Re: rollover conflict

Bao Vo
In reply to this post by jayecolina
I'm having the same problem with my preloaded rollovers. Would love some help with this or any alternative suggestions. THanks.

Here's the problem:
Tested many versions and things work when there isn't the preload script in the body tag like this

<body onLoad="preloadImages();">

when i delete that - shadowbox seems to work fine - but i have no rollovers.
Reply | Threaded
Open this post in threaded view
|

Re: rollover conflict

Bao Vo
I found a different very simple preload script that doesn't have to be placed inside the body tag - it's working okay for me now.

http://www.javascriptkit.com/script/script2/preloadimage.shtml
Reply | Threaded
Open this post in threaded view
|

Re: rollover conflict

jayecolina
I had a LOT of conflicting things happening with Shadowbox, but I seem to have resolved them one-by-one.

1) Different effects (photo gallery, video) would have different rates of success in different browsers. Sometimes a video would open correctly in FF -- but if I scrolled down the page in IE, the video would open partially above the window instead of being centered in the browser, depending on the position of the thumbnail or link on the original page. The videos won't open at all in Safari (the photo galleries do, however).

2) When I changed the doc heading from <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"> to <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 //EN"> many (but not all) of the layout tables using cell spacing got knocked out of kilter on my thumbnails. I resolved this by making a frame effect graphically around the thumbnails instead of in code.

3) I found that using the heading <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> seemed to alleviate the positioning problems of the video window mentioned above.

4) I too, had problems with preloaded images. Maybe because I have so much code on my pages left over from previously made pages, I found I could delete the PRELOAD code and the rollovers appear anyway. Today I did rollover links to Shadowbox and I simply unchecked the PRELOAD ROLLOVER IMAGES in the INSERT ROLLOVER BOX when making them in Dreamweaver. This doesnt seem to affect their operation.

To summarize: It seems in my case the most important elements to be careful about are the Document Heading and Preloading of rollover images. If anyone else has any suggestions, they will be appreciated.

J.C.