shadowbox overlaying devalvr plugin

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

shadowbox overlaying devalvr plugin

aiwetir
This post was updated on .
hi i've got shadowbox working on every supported (and more) browser, windows and mac, with quicktime and flash, but when i use the devalvr plugin (i know you never said it would work), it throws an error in safari, opera, and firefox3.where it fails.  ironically it works in ie6 and 7.  

it gives me an error on line 1785 which is:

            embeds[i].style.visibility = vis;

i'm hoping that this is something that you may be able to fix ??

i'll supply a link to my developing environment if it helps, but i can't guarantee that i'm not messing with things at the moment you look.  this is my smallest movie:

http://pdxvr.hopto.org/vr-6-17-low

there is a link on the top right that says 'view map'  this is where the shadowbox is.  you can test it and see that the other plugins allow the shadowbox to open, but not devalvr.  

the autodetect script should prompt you to get devalvr plugin, but if not, it's available at devalvr.com.

also, is this perhaps something that can be addressed by the devalvr plugin or detectvr.js autodetect script author (same person) ?

thanks in advance
-mmm


edit: i changed the subject of the post.  i should make it more clear that it's an issue with overlaying the plugin, not displaying the plugin.
Reply | Threaded
Open this post in threaded view
|

Re: shadowbox overlaying devalvr plugin

aiwetir
i've gotten it to work by removing

        var embeds = document.getElementsByTagName('embed');
        for(i = 0, len = embeds.length; i < len; ++i){
            embeds[i].style.visibility = vis;
        }


but it doesn't work in safari for windows.  i don't think that's much of an issue as i don't think anyone has visited my site using safair for windows, but i think that there is probably a better way of handling this overlay issue that just deleting that bit of code.